Commit ea1d3bc0 by Tobias

updated debian patches

1 parent cc08bd3f
......@@ -4,7 +4,7 @@ adjusted swt dependency and maven-jar-plugin for debian
@@ -75,12 +75,16 @@
<plugin>
<artifactId>maven-jar-plugin</artifactId>
<version>2.6</version>
<version>3.0.2</version>
- <executions>
- <execution>
- <id>default-jar</id>
......@@ -17,7 +17,7 @@ adjusted swt dependency and maven-jar-plugin for debian
+ <addClasspath>true</addClasspath>
+ <mainClass>org.stegosuite.Stegosuite</mainClass>
+ <classpathLayoutType>custom</classpathLayoutType>
+ <customClasspathLayout>/usr/share/java/$${artifact.artifactId}$${dashClassifier?}.jar</customClasspathLayout>
+ <customClasspathLayout>/usr/share/java/$${artifact.artifactId}$${dashClassifier?}.jar</customClasspathLayout>
+ </manifest>
+ </archive>
+ </configuration>
......@@ -32,6 +32,6 @@ adjusted swt dependency and maven-jar-plugin for debian
- <artifactId>${swt.artifactId}</artifactId>
+ <groupId>org.eclipse.swt</groupId>
+ <artifactId>org.eclipse.swt</artifactId>
<version>4.5.2</version>
<version>4.6</version>
</dependency>
<dependency>
......@@ -9,8 +9,8 @@ added gtk2 fallback for certain configurations
+gtk3_version=`dpkg -s libgtk-3-0|grep '^Version' | cut -d'.' -f2`
+swt4_version=`dpkg -s libswt-gtk-4-java|grep '^Version' | cut -d'.' -f2`
+
+# Run with GTK2-fallback if swt<=4.5 and gtk>=3.20
+if [ \( "$gtk3_version" -ge 20 \) -a \( "$swt4_version" -le 5 \) ]; then
+# Run with GTK2-fallback if swt<=4.7 and gtk>=3.22
+if [ \( "$gtk3_version" -ge 22 \) -a \( "$swt4_version" -le 7 \) ]; then
+ env SWT_GTK3=0 java -jar $STEGOSUITE_CLASSPATH $@
+else
+ java -jar $STEGOSUITE_CLASSPATH $@
......
Styling with Markdown is supported
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!